Play from here - problem

I have the setting: “Album track click action” = “Play from here”, but when I’m trying to play from a track it starts from the beginning of the album. As I remember it was not like this before but I can’t configure so it starts from the selected track. If I change to “Same as track” it changes but then only add the selected track and not the tracks after. I have restored a backup but the problem remains.


I tested with the latest MAFA version and can’t seem to reproduce this issue.
One possible reason may be that the tracks in the album are not tagged with Track number tag.
To help me debug this, please let me know your MAFA version and MPD version.

Also please check if the tracks are tagged with Track number and also try other albums to eliminate the possibility of mis-tagged tracks in this specific album.


All my albums are tagged with track numbers and the problems are the same.
For the moment I have two MPD installations running on two different computers,
versions 21.11 (Ubuntu 20.04 LTS) and 23.5 (Ubuntu 22.04 LTS). The MAFA client
on my Sony Xperia gives me the same problem. I am using 1.8.0 (beta tester).
I am using httpd flac strem for listening with bluetooth headphones from my
phone. As I remember the problem was not like this “before”, but most of the
time I am listening to full albums so I can’t be completely sure. It’s not a big
deal for one album, it is easy to junp forward. But when it comes to a box of
albums it’s more difficult.


So far the only way I was able to reproduce this is by disabling the Track tag from the server info view.

Hi again,

Thanks a lot, you solved my problem and really made my day!

I have added “track” to my two “mpd.conf” and now it works as expected
with both versions.

Old line: metadata_to_use “artist,album,title,date”
New line: metadata_to_use “artist,album,title,track,date”

The old line is a copy from when I was using “Ap-Linux 5.0” earlier and
as I’m normally listening to full albums I have never noticed the “problem”.

Do you have any more suggestions about adding more tags to “metadata_to_use”
to make my use of MAFA even better?

Thanks again for your quick support and the good work with the outstanding client
for MPD.


It depends on your preferences and how your music collection is tagged.

I usually enable all the tags in MPD’s config file:

metadata_to_use “+comment”

By default, all tags but comment are enabled. The above adds the Comment tag.

Even if you enable all the tags in MPD, you can still customize the MAFA main view to show selected tags. This way you can have the full tags in the lists and details views and have a cleaner main view with only the tags you like to browse by.